Pic - K150 ICSP Programmer (HCDVBD0002)

Microchip PIC development boards and accessories
andrew
Site Admin
Posts: 822
Joined: Sun Aug 05, 2012 4:15 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by andrew » Thu Jan 22, 2015 9:41 am

Ok well as mentioned it looks like you have everything installed ok and if your PIC devices are working then the only thing I can suggest now, if it is easy for you to do, is to try programming them via the ICSP header to rule out a problem with the ZIF socket.

Failing this I'm afraid it may have to be returned back to testing. I can't find you on our system but if you did buy it from us can you contact us at support [at] hobbycomponents.com and will resolve it from there.
Comments made by this poster do not necessarily reflect the views of Hobby Components Ltd.

swharper
Posts: 1
Joined: Mon Jan 26, 2015 12:00 am

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by swharper » Sat Jan 31, 2015 6:55 pm

Andrew the solution of changing the value in the chipdata.cid file for the 16F628A from 50 to 70 fixed the problem with the EEPROM write. Thanks very much for the post.

andrew
Site Admin
Posts: 822
Joined: Sun Aug 05, 2012 4:15 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by andrew » Mon Mar 02, 2015 11:51 am

That's great. I would suspect that the original creator of this software wasn't able to confirm timings with every variation of PIC device (for obvious reasons) so made an educated guess.
Comments made by this poster do not necessarily reflect the views of Hobby Components Ltd.

Totoche95
Posts: 5
Joined: Tue Apr 21, 2015 5:33 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by Totoche95 » Tue Apr 21, 2015 7:41 pm

Hello,
I have a K150 since a week, it works and it can also program PIC by ICSP. Just one thing, is there a solution to let ICSP connected after programming, when PIC is running. I have to disconnect ICSP to run my PIC card , it would be fine to let K150 connected.
Cheers
Yves

andrew
Site Admin
Posts: 822
Joined: Sun Aug 05, 2012 4:15 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by andrew » Wed Apr 22, 2015 1:18 pm

I have one set up using out PIC16F877A development board but I can't seem to replicate your issue. On my setup the the PIC will start executing as soon as it has been programmed. It sounds like the rest pin is being held (?) but this is not normal behaviour. You could try disabling the serial port under the file menu (ctrl+O) or try switching ICSP mode under the options menu.
Comments made by this poster do not necessarily reflect the views of Hobby Components Ltd.

Totoche95
Posts: 5
Joined: Tue Apr 21, 2015 5:33 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by Totoche95 » Wed Apr 22, 2015 2:22 pm

Thanks for your reply.
My card has a 16F628A, the same as the K150 programmer , my Microburn software is V150807 version with P18A protocol.
The programmer is a TS8900-K150 with P18A firmware.
All works fine, i can program also by ICSP but i have to disconnect ICSP connector to run the card, if not all ports of the pic have about 1.5 V, reset also.
I tried to do what you said, no difference.
Can you tell me what is your configuration, the model of pic programmer and programming software ?
Cheers.
Yves

andrew
Site Admin
Posts: 822
Joined: Sun Aug 05, 2012 4:15 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by andrew » Wed Apr 22, 2015 3:41 pm

Our K150 programmers are also shipped with version P18A firmware. You could try downloading the microbrn software in the first post of this forum. It should work with your programmer. If you still have the same problem then it will point to the problem being caused by a hardware difference rather than software.
Comments made by this poster do not necessarily reflect the views of Hobby Components Ltd.

Totoche95
Posts: 5
Joined: Tue Apr 21, 2015 5:33 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by Totoche95 » Fri Apr 24, 2015 3:21 pm

Thanks for your reply.
I tried with your software (that is the same as mine), same problem so it is hardware of TS-8900 K150. But it is not so bad, i just have to connect and disconnect ICSP connector each time i program the PIC. It works fine for the other.
Cheers
Yves

Totoche95
Posts: 5
Joined: Tue Apr 21, 2015 5:33 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by Totoche95 » Sat Apr 25, 2015 4:16 am

Hello, i found why, the voltage on reset pin of the pic was 1.5 V with K150 connected because VPP1 and VPP2 are connected together to VPP of ICSP with two 10K to ground. My reset resistor was also 10K so i had 1.5V. Finaly i put a diode on VPP and i have 5 V on reset input and my PIC restart after programming or reading. I also not connected VCC from the ICSP to avoid conflict with my card power supply. It is OK. But i don't know why VPP1 and VPP2 are connected together on VPP on my TS8900-K150 ?
Cheers

andrew
Site Admin
Posts: 822
Joined: Sun Aug 05, 2012 4:15 pm

Re: Pic - K150 ICSP Programmer (HCDVBD0002)

Post by andrew » Mon Apr 27, 2015 9:22 am

Without seeing a schematic I believe VPP1 & VPP2 are the same thing and are just used so that this programming voltage can be switched to different points on the ZIF socket depending on what chip is selected.
Comments made by this poster do not necessarily reflect the views of Hobby Components Ltd.

Post Reply