Reply to topic  [ 73 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8
Hobby Components USB 8CH 24MHz Logic Analyser (HCTEST0006) 
Author Message

Joined: Mon Mar 20, 2017 8:48 am
Posts: 2
Post Re: Hobby Components USB 8CH 24MHz Logic Analyser (HCTEST000
Thanks for the very fast reply Andrew.

Quote:
I do notice from the sigrok-cli scan that it is complaining that it can't find the firmware file (fx2lafw-sigrok-fx2-8ch.fw). This is the firmware that gets transferred into the analysers RAM when Sigrock first initialises the analyser.

Do you have this file on your computer? If not you may want to take a look at step 3 in the Linux install guide in the first post of this thread.


This was indeed the problem. After downloading the .fw file, it is working.

Thanks again :D


Mon Mar 20, 2017 4:55 pm
Profile

Joined: Mon May 08, 2017 5:18 pm
Posts: 1
Post Re: Hobby Components USB 8CH 24MHz Logic Analyser (HCTEST000
I am trying to get the this working on Ubuntu 17.04

I have installed the sigrok package, which seems to be up to date and followed the instructions on page 1 of the thread. I seem to be in the same position as Anthony on page 6.

Code:
sigrok-cli -V
sigrok-cli 0.5.0

Using libsigrok 0.3.0 (lib version 2:0:0).
Using libsigrokdecode 0.3.0 (lib version 2:0:0).


The USB id is OK

Code:
lsusb -s 4
Bus 003 Device 004: ID 1d50:608c OpenMoko, Inc.


But the device is not found.

Code:
sigrok-cli -d fx2lafw -c samplerate=1mhz --samples 1m -o foo.sr -l 5
sr: libsigrok loglevel set to 5.
sr: backend: Sanity-checking all drivers.
sr: backend: Sanity-checking all input modules.
sr: backend: Sanity-checking all output modules.
srd: libsigrokdecode loglevel set to 5.
sr: hwdriver: Initializing driver 'fx2lafw'.
sr: hwdriver: Scan of 'fx2lafw' found 0 devices.
No devices found.


Has anyone had success with this on Ubuntu & can give any pointers to get it working?

Thanks


Mon May 08, 2017 5:35 pm
Profile
Site Admin

Joined: Sun Aug 05, 2012 4:15 pm
Posts: 659
Post Re: Hobby Components USB 8CH 24MHz Logic Analyser (HCTEST000
Due to the large range of configurations and versions of Linux I'm afraid we cannot support use of the analyser with Linux. Hence why it is only advertised to work with Windows. However we did have success in getting it to work with a clean install of Ubuntu Linux and posted a guide in the first post of this thread. Did you try following this guide rather than the one on the Sigrok site?

_________________
Comments made by this poster do not necessarily reflect the views of Hobby Components Ltd.


Fri May 26, 2017 2:45 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 73 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Thank you to phpBB.com & phpBB.ro.
Design created by Florea Cosmin Ionut.
© 2011 All contents of this site are © Hobby Components LTD